'Incorrect client version' issue after new update

WaterylilyWaterylily Posts: 1Member Beginner
edited September 23 Technical Support
I can't play the game after the new update.. when connecting do I just get a message saying 'Incorrect client version' and clicking 'Yes' closes the game entirely. I've submitted a ticket regarding this issue but I was just wondering if this was happening to anyone else? I play on Steam. I hope this gets fixed soon.
Sign In or Register to comment.