Can not refine Weapon

why i using Blood Sleeping Dragon but "not the proper material for refining" appare ?


  • There's an issue with refining which results in the "Improper Material" message, even with correct materials. It's reportedly due to issues with the game files, so re-logging or re-installing may correct it temporarily. But we're collecting incidents and reporting them in order to get a permanent solution.

    If you've lost valuable items like Tender Stones to bugged crafting attempts, please send a support ticket. We'll document the case for the devs, and we may be able to refund the lost items in some cases.

  • Had this before and seems to be an issue with game files.

    This fixed it for me:

    On my PC made a new folder and moved all file from 9d folder to the new one (cut&paste). Started game from new folder and it worked after.

  • edited August 2021

    It seems it doesn't work for everybody.

    Moved the game multiple times within different directories and/or installed a few copies ... still can't use the weapon refinement.

Sign In or Register to comment.