Isn't manual looting a thing anymore?

So I saw this topic (http://archivedforum.papayaplay.com/index.php?p=/discussion/368140/did-the-looting-change) but no one ever responded to it, so I'm asking it here again.

What that player mentioned is still correct:

That's when I noticed that the loot button was green instead of pinkish purple. I didn't pay much mind to it, though. Anyway, I figured out that my skills have been reset (this seems to happen every time I play the game again after a long break). It doesn't matter. I don't mind that too much, though I think that might still be a problem.

So I filled in the skills and began attacking some monsters. Oh, look, some loot! My auto-looting pet expired, so I have to pick it up manually. No problem! So I press the usually loot button and see my character do the normal "picking up" animation. However, the bag remained. No sign of anything picked up. I tried again and again, and nothing. That's when I curiously hovered my mouse over the loot button and saw that it only loots quest items. I thought this might be separate from the regular loot button...

I went into the skills tab to check out the support skills. There was only one button for looting. What's going on here? Can my character not pick up items manually anymore if the items are not items for a current quest? I'll see if my character can pick up items for a quest and reply to my comment on the results.


The tl:dr version is, Can you not manual loot the loot bags that monsters drop anymore?

I haven't gone into a dungeon yet, but will it be the same there?

Comments

  • I haven't been having any problems with picking up any loot after not playing for awhile. Have you tried battling other enemies and seeing if there's still a problem? Is this just happening with bosses? Have you looked through your separate inventory tabs to see if they're filled up?

  • I only tried it out in the fields where I wasn't able to pick anything up.

    When I looked through my inventory I had enough free slots.

    There I also saw an Immortal Plant with which I reactivated one of my pets, so now that one is picking up everything now. (I deactivated autoloot but still can't do it myself, even though my character does do that pick up emote)

  • Maybe you need to email the people in control of the game. This is a very strange problem to keep having.

Sign In or Register to comment.